SmartQuant Discussion

Automated Quantitative Strategy Development, SmartQuant Product Discussion and Technical Support Forums
It is currently Thu Oct 01, 2020 9:28 am

All times are UTC + 3 hours




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Sat Sep 22, 2012 3:11 am 
Offline

Joined: Thu Jun 08, 2006 3:56 pm
Posts: 537
Location: BC Canada
I have a small script that I use for creating new instruments (posted elsewhere in these forums), but it uses some fields that are part of the FIX specification. I used the following using statements in the scripts:

Code:
using SmartQuant.Data;
using SmartQuant.Instruments;
using SmartQuant.FIX;

However, I just tried to use the script for the first time in a long time on my OQ Win7 x64 installation, v3.2.2 x64 bit, and OQ will not allow me to add the DLL references listed above to my list of build references. Here is the script code that I'm trying to run:
Code:
   Instrument inst = new Instrument (sym, FIXSecurityType.Future);
         inst.Currency = "USD";
         inst.SecurityDesc = pDesc;
         inst.SecurityExchange = pExchange;
         inst.SecurityID = pIbSym;
         inst.SecurityIDSource = "IB";
         inst.Factor = pFactor;          // ticksize * factor = $dollars/tick
         inst.ContractMultiplier = pFactor;
         inst.Margin = pMargin;
         inst.TickSize = pTickSize;
         inst.PriceDisplay = pPriceDisplay;
         inst.MaturityDate = numDates[n];

What can I do to get my script running again? Thanks


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC + 3 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group