SmartQuant Discussion

Automated Quantitative Strategy Development, SmartQuant Product Discussion and Technical Support Forums
It is currently Mon Sep 28, 2020 6:01 pm

All times are UTC + 3 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Simulation problems
PostPosted: Thu Nov 21, 2013 11:17 am 
Offline

Joined: Wed Aug 08, 2007 6:32 pm
Posts: 236
Hi I am trying to run a simulation that executes using FillOnBar but nothing is happening

I built this test system:

using System;
using System.Drawing;

using OpenQuant.API;
using OpenQuant.API.Indicators;

public class MyStrategy : Strategy
{
public override void OnStrategyStart()
{
}

public override void OnBar(Bar bar)
{
if(bar.Close>bar.Open)
Buy(1);
else
Sell(1);
}
}

and these are my settings but nothing is happening.

Attachment:
Capture1.PNG
Capture1.PNG [ 17.97 KiB | Viewed 2300 times ]


Can anyone tell me why? am I missing something? Btw it works fine with FillonTrade.


Top
 Profile  
 
 Post subject: Re: Simulation problems
PostPosted: Fri Dec 20, 2013 2:56 pm 
Offline

Joined: Wed Aug 08, 2007 6:32 pm
Posts: 236
Looks like it was a problem stemming from relocating the data. only solution was to completely wipe OQ from the system and re-installing the whole system.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC + 3 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group