SmartQuant Discussion

Automated Quantitative Strategy Development, SmartQuant Product Discussion and Technical Support Forums
It is currently Sat Jun 23, 2018 11:31 am

All times are UTC + 3 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Tue Mar 03, 2015 9:33 am 
Offline

Joined: Thu Feb 05, 2015 11:15 am
Posts: 17
Hi

When I am tring to connect TTAPI provider in OpenQuant, I am facing this error:

Quote:
System.BadImageFormatException: Could not load file or assembly 'TradingTechnologies.TTAPI, Version=7.17.30.0, Culture=neutral, PublicKeyToken=423079b15fc884a6' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'TradingTechnologies.TTAPI, Version=7.17.30.0, Culture=neutral, PublicKeyToken=423079b15fc884a6'
at SmartQuant.TT.TTAPI.elRatryk0V()
at SmartQuant.TT.TTAPI.PeNaCRLu4K(Object )

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].


My OpenQuant and TTAPI is 32-bit. QuantRouter can connect with TTAPI provider.

Can you help me with this?

Thanks


Top
 Profile  
 
PostPosted: Tue Mar 03, 2015 9:43 am 
Offline
Site Admin

Joined: Thu Jul 17, 2003 10:39 am
Posts: 1478
Hi,

You need to install TT API package 32bit from TT web site (not 64) in order to use it with OpenQuant.

_________________
SmartQuant Development Team


Top
 Profile  
 
PostPosted: Wed Jun 20, 2018 11:05 pm 
Offline

Joined: Tue May 27, 2008 10:44 pm
Posts: 37
Getting a similar error message while trying to connect to the TT API. Using Windows 7 64bit, X_TRADER Pro 7.17.84.7, TT API 7.17.84.2 64bit and the OpenQuant 2014 trial. It won't work. Please help!

System.BadImageFormatException: Could not load file or assembly 'TradingTechnologies.TTAPI, Version=7.17.65.0, Culture=neutral, PublicKeyToken=423079b15fc884a6' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'TradingTechnologies.TTAPI, Version=7.17.65.0, Culture=neutral, PublicKeyToken=423079b15fc884a6'
at SmartQuant.TT.TTAPI.DispatcherThreadInternal()
at SmartQuant.TT.TTAPI.DispatcherThread(Object obj)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].


Top
 Profile  
 
PostPosted: Fri Jun 22, 2018 3:33 pm 
Offline

Joined: Tue Aug 05, 2003 3:43 pm
Posts: 6803
Hi,

we've checked TT API with OQ 2014 and it works fine on our side, so it looks like there are issues with your TT x32/x64 setup. I suggest you check your TT installation.

We will be back to you later today with more hints.

Regards,
Anton


Top
 Profile  
 
PostPosted: Fri Jun 22, 2018 8:08 pm 
Offline

Joined: Tue May 27, 2008 10:44 pm
Posts: 37
Thanks for the response Anton. Reinstalled everything but still no luck.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC + 3 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group