SmartQuant Discussion
http://www.smartquant.com/forums/

ITinvest адаптер
http://www.smartquant.com/forums/viewtopic.php?f=65&t=8406
Page 13 of 14

Author:  newDave [ Thu Sep 15, 2011 3:51 pm ]
Post subject:  Re: ITinvest адаптер

Что то вы затянули с выходом обновления. Уже две недели прошло.
Когда можно ожидать?

Author:  Dr. Anton Fokin [ Thu Sep 15, 2011 5:01 pm ]
Post subject:  Re: ITinvest адаптер

Завтра устроит? Если сможем, конечно...

Author:  Alexei Kurov [ Fri Sep 16, 2011 2:58 pm ]
Post subject:  Re: ITinvest адаптер

newDave wrote:
День добрый,
я тут решил сдуру установить последнюю версию SmartCOM 2.1.48 от 29.03.2011 в итоге у меня OQ вообще отказывается подключаться.
В окошке Provider Errors написано
Id -1
Code -2147023836
System.Runtime.InteropServices.COMException (0x80070424): Creating an instance of the COM component with CLSID {DEA17435-B62C-4F13-BEC8-08EBD203B281} from the IClassFactory failed due to the following error: 80070424.
at SmartQuant.ITinvest.SmartCOM.Connect()

Ранее стоял вроде 2.1.46.999

Вы не поддерживаете последнюю что ли ?

А вы не пробовали между uninstall'ом 2.1.46 и install'ом 2.1.48 комп перегрузить? Дело в том, что uninstaller не удаляет сервис смарткома, а только помечает его "к удалению". инсталлятор новой версии поэтому не может обновить его и в итоге нет ни старого ни нового сервиса - и получаем эту ошибку. А в плане COM интерфейса ничего не изменилось и вполне "старый" плагин работает с 2.1.48

Author:  newDave [ Sun Sep 25, 2011 11:21 pm ]
Post subject:  Re: ITinvest адаптер

Только что попробовал еще раз - ошибка сохраняется. Если ставлю обратно версию *.46 - все работает. (OQ пока не обновлял - но вы собственно утверждаете это и не нужно в данном случае.). Операционка Win Server 2008.

Author:  Alexei Kurov [ Mon Sep 26, 2011 11:30 am ]
Post subject:  Re: ITinvest адаптер

Я все-таки склонен думать, что проблема в переустановке СмартКома. Специально сейчас поставил .48 на вин 2008 - все работает. Попробуйте либо на другой машине, либо переустановить смартком след. образом - удаление версии .46, перезагрузка, убедиться что сервис SmartCom2 отсутствует в списке служб виндоуз, а также все удалено из папки program files(х86)-> ic it invest (да и сама папка тоже), поставить .48

P.S. И все-таки мы рекомендуем использовать последние версии ОпенКванта, если нет каких-то серьезных причин этого не делать - не зря же мы обновления выпускаем.

Author:  newDave [ Sun Oct 09, 2011 3:30 pm ]
Post subject:  Re: ITinvest адаптер

Выполнил вручную команду cmd sc delete SmartCOM2 - после этого походу заработало.
Спасибо

Author:  sda75 [ Wed Nov 16, 2011 10:40 am ]
Post subject:  Re: ITinvest адаптер

Как в через SmartCom получить состояние аккаунта -
например через GetBrokerInfo - я не могу получить заявки (список, состояние)
что делать ?

Author:  Alexei Kurov [ Wed Nov 16, 2011 11:02 am ]
Post subject:  Re: ITinvest адаптер

SmartCom в нынешнем виде не передает заявки в BrokerInfo, только позиции и данные по счету

Author:  newDave [ Wed Nov 16, 2011 2:33 pm ]
Post subject:  Re: ITinvest адаптер

А жаль. Мне тоже было бы интересно.

Author:  Alexei Kurov [ Wed Nov 16, 2011 2:46 pm ]
Post subject:  Re: ITinvest адаптер

добавил в туду.

Author:  kvg314 [ Fri Dec 23, 2011 2:18 pm ]
Post subject:  Re: ITinvest адаптер

Решил проверить и понять - подойдет ли OQ для моих задач.
Завел демо-счет на It
Скачал OQ
пытаюсь повторить видео. На этапе загрузки Tickers - пустота.
Smartcom версии 2.2
В логах вроед ничего подозрительного. Помогите.... А то прошлая попытка с адаптером от Альфы так же провалилась. Но очень хочу OQ.

Author:  Alexei Kurov [ Fri Dec 23, 2011 2:33 pm ]
Post subject:  Re: ITinvest адаптер

OQ еще не совместим со SmartCOM 2.2 - по-крайней мере не тестирован.
Работает с версией 2.0
Они (ITinvest) обратной совместимостью АПИ не озабочены

Author:  newDave [ Fri Dec 23, 2011 8:14 pm ]
Post subject:  Re: ITinvest адаптер

Алексей хотелось бы и с версией 2.2 подружиться.
У них там написано что они фиксили/меняли:
- Вызов события UpdateOrder по каждому тику, избыточные вызовы Cancel, Pending и тд.

У меня такое ощущение, что это возможно то, от чего приходится страдать в 2.0 хотя я не уверен конечо.

Author:  Alexei Kurov [ Sat Dec 24, 2011 11:36 am ]
Post subject:  Re: ITinvest адаптер

Разумеется, подружимся, только уже скорее всего после праздников.

Author:  zyko [ Thu Feb 23, 2012 4:42 pm ]
Post subject:  Re: ITinvest адаптер

Небольшая проблемка:
При работающей связке OQ3.4.0+SmartCOM2.2 комп аварийно завершил работу.
После этого адаптер при соединении:
- пишет в эрроз "Unexpected disconnect, reason=Timout detected. check your internet connectivity or event handler code"
- светофорчик зелёный, но меню "Disconnected" недоступно, а доступно "Connected"
- при попытке нового коннекта либо автоматом, либо вручную, получаю новый эррорз
- в логе адаптера пишется:
Code:
2012-Feb-23 17:04:53.176163 [TID=8e48] - INFO : ping status = 1014 ms bytes_send = 1812 bytes_rcvd = 0
2012-Feb-23 17:04:54.190165 [TID=8e48] - INFO : dm_ping_listener: timeout on trades feed. disconnection forced. 2028
2012-Feb-23 17:04:54.190165 [TID=8e48] - INFO : ping status = 2028 ms bytes_send = 1812 bytes_rcvd = 0
2012-Feb-23 17:04:54.190165 [TID=8e48] - INFO : dm status changed  ... new status : -2 error_id : 0
2012-Feb-23 17:04:54.190165 [TID=8e48] - INFO : connecttion finalized ...
2012-Feb-23 17:04:54.190165 [TID=8e48] - INFO : setting disconnected event ...
2012-Feb-23 17:04:54.190165 [TID=8e48] - INFO : disconnection event propagated to client.
2012-Feb-23 17:04:54.190165 [TID=8e48] - INFO : disconnected event set ...
Переустановка адаптера и опенкванта не помогает. Чистил все папки и реестр.

Чтение форума смарткома показало, что проблема иногда возникает и, цитирую: "это означает что у вас цикле выборки данных тормоза, приложение тормозит и блокирует интерфейс на колбеках". Насколько я могу понять, то, что отправляет серверу смартком сервер не воспринимает, и адаптер считает это плохой связью.

Не подскажете, как победить?

Page 13 of 14 All times are UTC + 3 hours
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/